So first things first. I want to give some background infomation.

I woke up to my phone not reading my sim and with that i couldnt turn on my wifi and had random reboots. as described here: https://www.reddit.com/r/Xiaomi/comments/ewz3vj/no_sim_no_wifi_device_is_locked/
i tried to fix it with alot of things: flashing (got stuck on flashing. even after a whole night), installed TWRP and tried to flash it from there (my OS still did werid). after that i deleted my OS and everything and tried to install a new rom using adb and that got me stuck on ''android setup isnt responding''. Now i tried to flash another rom using twrp, that didnt work and twrp wasnt reachable while holding up and power button. that would send me to the mi-recovery. Now i am stuck with that and is i try to reboot i get sent back to fastboot.

Now, i found that it wasnt my SIM card since others would do the same thing. I would also be abke to use wifi when not having a SIM so the problem mustve been somewhere in the firmware.

Do you guys have any clue on what i could do to resolve my whole situation?