In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .


[Product] [problem/issue] Roborock S5 (2nd gen) - firmware 3.3.9_001886 - Map loading no longer works on iOS

2020-02-24 05:23:31
4881 4
Is anyone else having issues with their Roborock S5 vacuum cleaner? On iOS the map never loads and only shows "Map loading" with the animated sweeping robot icon. On Android it works fine.

Robot firware: 3.3.9_001886
Xiaomi Home app version: 4.26.0
Plug-in version: MI_RZ_38
iOS: 13.3.1 (iPhone 11pro)

What we tried:
  • Terminate(close completely) and restart Xiaomi home app.
  • Restart iPhone.
  • Reconnect the Mi account in the Xiaomi home app.
  • Reset wifi on vacuum.
  • Reset vacuum completely and added it as a new vacuum in Xiaomi Home app.
  • Turned off "Map saved mode (Beta)"

None of this solved the issue. The map still won't load. Has anyone else had this problem, and if so, (how) did you manage to 'fix' it?
It's still in warranty for another 20 months so I could take it back to the store. However, as it works fine on Android it seems to be a software issue.
2020-02-24 05:23:31
Favorites1 RateRate


hanizzo | from Mi MIX 2S


'Map saved mode (Beta) must be enabled..
try to just enter press 'clean'..I've read someone did this and the map showed up again...
can you try that?
if not please send a message to
best regards,
2020-02-26 08:42:19
Invalid floor, the posts have been deleted #2

Rookie Bunny

1868663049 | from mobile


'Map saved mode (Beta) must be enabled..
try to just enter press 'clean'..I've read someone did this and the map showed up again...

For me, log out / log in in the Xiaomi Home application solved the issue.
2020-03-21 01:30:35

Rookie Bunny

Amcintyr | from app


I’m having the same problem. No map on iOS, but working on Android.  

Firmware v3.5.7_002008
App v4.28.2
iOS v13.3.1
2020-04-13 09:11:08
please sign in to reply.
Sign In Sign Up


Rookie Bunny

  • Followers


  • Threads


  • Replies


  • Points


Read moreGet new

Mi Comm APP

Stay updated on Mi Products and MIUI

Copyright©2010-2020, All Rights Reserved
Quick Reply To Top Return to the list