In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Xiaomi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .

Redmi Y/S Series

[Q&A] No service after using Xiaomi.EU

2019-06-10 05:29:43
3521 9
Please helpThis is what I did

1. I was on MIUI 10 Global 10.3.2
2. I flashed Xiaomi.EU Oreo... it was working fine
3. I flashed Xiaomi.EU Pie... it was also fine
4. I decided to flash back MIUI 10 Global 10.2.1
this is where my troubles began


1. No SIM detected when I insert both SIMs, sometimes SIM 1 is briefly detected then it disappears
2. Same Issue when I only insert SIM 1
3. When I insert SIM 2, I can only use 3G/2G data, phone calls are completely silent
4. When I try to flash any ZIP in a custom recovery, they always fail with:
    Error 7 and
   E1001: Failed to update system image

What I have tried
1. Flashing global rom
2. Flashing China rom
3. Flashing original MIUI 9 rom
4. Flashing above roms through EDL
5. Flashing modem only
6. Flashing old modem
7. Sent to a service center to have the SIM components changed.

Any help would be appreciated, please and thank you if you took the time to read this through.
2019-06-10 05:29:43
Favorites1 RateRate
Dear Mi Fan,
   Downgrading Android version or MIUI, both usually causes baseband data loss. To fix this, you need to flash your phone with latest MIUI ROM using Mi Flash Tool, hopefully twice.
2019-06-16 09:49:37
Always believe that something wonderful is about to happen!

Master Bunny

LAYLATALACKOVA | from Redmi Note 6 Pro


Xiaomi eu it's better and good.  maybe you have a blocked phone by Xiaomi you need use fastboot I think
2019-06-10 06:42:51

Pro Bunny

John Lloyd Paraon | from Redmi S2


I think it's because the Rollback Protection feature on the new Android Pie ROM is half-baked, and it's not allowing downgrades to ysl's modem. I also did downgrade to Stable Oreo but I also noticed I don't get network coverage so I upgraded back to Pie.
2019-06-10 07:42:00

Advanced Bunny

2EZ4_tRaP | from Redmi Y2


Please Visit XDA Redmi S2 Forum
There Is Thread Which Will Help You For Sure.
Downgrading To Oreo From Pie Will Cause Baseband Lost.
2019-06-10 17:36:32

I had the same problem. For now I'm only using 3G and it's working for me.
2019-06-10 19:39:32
Invalid floor, the posts have been deleted #5
Wallacy1k replied at 2019-06-10 16:17:08
fix bugs

Muchas Gracias!!!! I fixed it with this!
Although, I already bought a Redmi Note 7 but I'll give this to my mom.
2019-06-11 05:07:23

Master Bunny

tZe_vitamin | from Redmi Note 7


Muchas Gracias!!!! I fixed it with this!
Although, I already bought a Redmi Note 7 but I'll give this to my mom.

what did you do,how did you fix this?
2019-06-12 13:31:57
Invalid floor, the posts have been deleted #8
please sign in to reply.
Sign In Sign Up


Rookie Bunny

  • Followers


  • Threads


  • Replies


  • Points


Read moreGet new

Xiaomi Comm APP

Stay updated on Mi Products and MIUI

Copyright©2010-2021, All Rights Reserved
Quick Reply To Top Return to the list