In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Redmi 6/6A/Pro

[Q&A] Redmi 6 Global Stable 10.3.2.0: Cannot install TWRP using fastboot flash recovery

2019-05-13 10:52:06
722 3
Hi! Today I pasted my 15 days temporal block, so I was ablo to unlock my Redmi 6 phone.

The unlock seems OK: I see the open-lock icon during bootstrap and I read OEM Unlok: Unlocked and Mi Unlock Status: Unlocked into Developer options. I tried the standard recipe to install the TWRP recovery, once rebooted in bootloader I executed from the PC:
fastboot flash recovery twrp-3.3.0-0-cereus.img
fastboot boot twrp-3.3.0-0-cereus.img
The first command seems OK, no errors are reported. But the following reboot brings the regular operating system, not Recovery at all. The image I used is the official twrp-3.3.0-0-cereus.img. If I reboot in recovery, I still find the stock Mi-Recovery 3.0.

The phone is updated to the MIUI Global 10.3 Stable 10.3.2.0 (OCGMIXM).

Does anybody have any clue? Thank you.
2019-05-13 10:52:06
Favorites RateRate

Device team

Sarge7 | from Redmi Note 5

#1

The install method for twrp 3.3.0.0 has changed .
  The following link tutorial is for latest twrp & not 3.2.0.0 as in link description.
    https://www.thecustomdroid.com/download-install-twrp-3-2-0-0-android/
    You could just use a previous version not optimised for Pie & A/B partitions.
   Don't forget to flash lazyflasher
2019-05-13 12:32:06

Rookie Bunny

6186467595 Author |

#2

Sarge7 replied at 2019-05-13 18:32:06
The install method for twrp 3.3.0.0 has changed .
  The following link tutorial is for latest twrp & ...

Hi Sarge7, thank you for your reply!

The problem is not installing TWRP, but booting it for the first time! My Redmi 6 model M1804C3DG, with system MIUI Global 10.3 Stable is running Android 8.1.0 (does not have default FBE File-based Encryption) and it does not have the A/B partition scheme.

I have solved the problem following the recipe contained in this post. The required trick is to flash two partitions: the regular recovery partition (using the TWRP image) and a partition named para (using a small file named misc.bin). If I understand well, flashing that second partition, disables the mechanism which will restore to factory recovery on each reboot.

Once started TWRP, I did the following:
  • Mounted System and Vendor partitions.
  • Executed Sign Boot from Advanced menu.
  • Installed Magisk-v19.1.zip which I already copied to /sdcard.

Please, can you explain to me if LazyFlasher is really needed? It seems that my phone is OK: system is running fine, root is available, TWRP recovery is available. Thanks!



2019-05-14 05:24:31

Device team

Sarge7 | from Redmi Note 5

#3

6186467595
Hi Sarge7, thank you for your reply!

The problem is not installing TWRP, but booting it for the f ...

Hi , that's very interesting .I've always used an older version of twrp so I've never encountered the problems users are facing now .
   Like yourself I'm going to have to research method & educate myself .
  As you booted with no problem you obviously did not need lazyflasher.
  I've only used it & not fully understood it's purpose as the majority of tutorials I've read have said it's important especially when using Miui to flash it to patch boot image after rooting & to prevent bootloop as well as other things which quite honestly I don't understand .

2019-05-14 08:32:48
please sign in to reply.
Sign In Sign Up

6186467595

Rookie Bunny

  • Followers

    0

  • Threads

    2

  • Replies

    1

  • Points

    13

Read moreGet new
Copyright©2016-2019 Xiaomi.com, All Rights Reserved
Content Policy
Quick Reply To Top Return to the list