In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .


[Other] Smart Home sometimes not so Smart

2019-02-06 19:10:41
543 8
Hi All,

Hope your up for little bit of reading   

I like to think of myself as a resourceful an determined person who is capable of fixing or finding workaround for tech problems in my life. Unfortunately I hit a bit of a wall with my Smart Home setup, and need some help from community. I have multipe YeeLight Smart LED Bulbs ( White and RGB ) that work great when using MiHome app or making Googel or Alexa switching them on / off / dimming or setting scenes.
Unfortunately my lazines went so far that talking to the house is sometimes just to mutch and I chose to invest further into Xiaomi eco-system of products.
Xiaomi Multifunctional Gateway ( sometimes refered to as Mi Control Hub), Wireless Aquara Light Switches and Door Sensors were added over weeks and months.
Most of the time everything works fine and as expected when pressing the light switch lights go on or off, when doors are open and its dark outside lights in hallway light up for few minutes to guide you thru and so on.
But as you can imagin from name of the thread there is issues that makes me, at this point, to go nuts.
Every now and than ( can be 3 times a day or once a week, no patern of sord ) when pressing a light switch the YeeLights don't do anything.
Now I know that :
- Lights are working ( because I can operate them using MiHome App or telling assistants to do theyr magic,
- Wireless Switch is still conected to Getaway (all automations have additionla request to turn light on Getoway for few secounds so I knowi ts registering),
- Getaway is still conected to Ruter (Listed as conected device ans also it has alocated IP Address to prevent any issues if too many devices on a network),

Dont know why Getaway and Aquara devices are not showing in Android MiHome App but are or used to be at lease perfectly happy in iOS one, unfortunalty after one of the updates something become broken and when selecting Getaway / Control Hub in iOS app is just displaying Failed to Initiolise Device.


Once Getaway is restarted everything goes back to normal and all functions are restored in less than a minute.

Anyone has any ideas what is happening or how can I fix it are welcome.I tryed to turn it Off and On again, reconect the devics and not looking forward to running RasperyPie as a server, but open to all imput.



2019-02-06 19:10:41
Favorites RateRate
OK, the Home ecosystem is not a specialty of mine, but I've passed it to our in-home Home guru, and he should be able to help :)
2019-02-07 05:25:23

Advanced Bunny

Welcomes Terrace Sin Author | from app


thanks, that sounds like a plan
2019-02-07 09:51:35

Advanced Bunny

Welcomes Terrace Sin Author | from app


Additional information.

Just experienced issue again. I took screenshots.

Odd thing is that error given is 1. Poor Network, 2. Device error and 3. Server error, but seconds later when I'm asking Google Home it just turned off the lights with no issues.
2019-02-10 13:57:50
Try change your DNS in your router (put it manual)

DNS 1: or
DNS 2: (this is a DNS from china)

for me works, more than 5 years using Mi home security kit and many news sensors, and dont have this problem.

All automatizacions go to server china and back to your Mi hub to execute, if there are some problem in the way, automatizacion dont work.
2019-03-16 05:20:52

Normas del Foro Oficial de Xiaomi, Mi Community
flashkaisel replied at 2019-03-16 09:20:52
Try change your DNS in your router (put it manual)

Thanks, will try to get in set up this weekend.
I think I looked into it in the past but couldn't get it all working on rutter, I'm with NowTv Broadband ( SKY) and I think they don't give rubost optopns for  setting up  DNS
2019-03-17 05:11:29
Welcomes Terrace Sin
Thanks, will try to get in set up this weekend.
I think I looked into it in the past but couldn't g ...

¿Do you have many devices attached to Chinese server?
The new Mi smart sensor set its coming, this smart hub work with European server, but at the moment only accept door/window sensor, move sensor and switch, i hope in no far future accept more sensors and devices.
2019-03-17 06:05:20

Normas del Foro Oficial de Xiaomi, Mi Community

Advanced Bunny

Welcomes Terrace Sin Author | from app


I have 9 oryginaly RGB YeeLights, 4 Aquare Light switches, 2 door sensors and that's all I think. Tried to move to EU server but can't get lights connected so reverted back to Singapore one. I was considering getting the new Smart Sensor Set but can't see any difference or improvements to what I already have. Also I tried to change DNS but no luck, I'm guessing SKY locked up NowTV router same as their own. will try to play with DDNS but that also seems to be limited to only few options
2019-03-19 15:15:40

Rookie Bunny

1656108026 | from mobile


I am having the same issue with the difference that I am not seeing any erorrs in the log area. So everything is working normal.
2019-07-18 15:24:39
please sign in to reply.
Sign In Sign Up

Welcomes Terrace Sin

Advanced Bunny

  • Followers


  • Threads


  • Replies


  • Points


3 Days Check-In
First 1k members
Halloween Alter-ego
Throw Back with Mi 2018
Valentines Day
Mi Bunny Winner
Redmi Note 7 Into Space
Android Q
15K UK

Read moreGet new
Copyright©2016-2019, All Rights Reserved
Content Policy
Quick Reply To Top Return to the list