not getting notification badge

Follow The Steps To Fix This Issue:-
1. Go to Settings
2. Select Apps & Notification
3. Select App Info
4. Find Messages and click on it
5. Click on Disable
6. Click On Enable
7. Select App Notifications
8. Toggle to On
9. Click on Additional settings in the app
10. Click on Default SMS app and select Messages by default if other app is active
11. Done

Reply back if it worked for you