I had the same few days ago when I've moved over to the new network provider for sim only deal, but apart from annoying notification everything works fine so i just disabled that notification by long pressing on the notification and options...