In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Xiaomi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Mi MIX 3/Mi MIX 3 5G

[Discussion] I can't connect to any open network

2021-06-26 07:11:07
362 8
Mi mix 3 5g

Whenever I connect to any open network (without password) which require me to log in I get this same message, I've tried in many different ones, and I'm not sure why it happens.
2021-06-26 07:11:07
Favorites RateRate

Super moderator

Torlyn | from app

#1

Using a completely open wifi network is really not something we recommend, as feankly anyone on that network can see EVERYTHING you are doing on your phone. At best, it's the equivalent of allowing a wannabe hacker to play with your unlocked phone, at worst it's a honeytrap designed to record all activity on there. That said, if you insist on using these, generally you need to go to the browser, try to load a page, and the WiFi should redirect you to a minimal sign in page, then you get authorised.
2021-06-26 12:04:23
If you mean connecting to public WiFi, Like in coffee shops etc, Try turning off private DNS or setting it on auto in phone settings and your browser settings. Using private DNS will stop the login page from loading.
2021-06-26 14:48:00
The UK community has now moved to a new platform. Click Here  If you are in the UK please visit Google Play Store and update the Community app.
Phone Settings - Connections and sharing, Private DNS. Turn off or may work on auto. In Google Chrome, Settings - Privacy and Security, Turn off use secure DNS or try Google.
2021-06-26 14:51:56
The UK community has now moved to a new platform. Click Here  If you are in the UK please visit Google Play Store and update the Community app.

Rookie Bunny

anasxfh Author | from app

#4

Torlyn
Using a completely open wifi network is really not something we recommend, as feankly anyone on that network can see EVERYTHING you are doing on your phone. At best, it's the equivalent of allowing a wannabe hacker to play with your unlocked phone, at worst it's a honeytrap designed to record all activity on there. That said, if you insist on using these, generally you need to go to the browser, try to load a page, and the WiFi should redirect you to a minimal sign in page, then you get authorised.

thanks for the feedback, I often try to not use them but sometimes you need to as your data is finished or need to so an important task online, I came Spain a few days back and needed WiFi to talk to my relatives, couldn't on the airport, couldn't on cafe, and couldn't on the hotel either, because of this issue, on Monday when shops opened I bought a sim card so I'm fine now.
2021-06-30 20:34:52

Rookie Bunny

anasxfh Author | from app

#5

South of the Humber
Phone Settings - Connections and sharing, Private DNS. Turn off or may work on auto. In Google Chrome, Settings - Privacy and Security, Turn off use secure DNS or try Google.

I'm not using any DNS, disabled secure DNS on Chrome and will update you guys, my phone is also free from network bought from Xiaomi UK, thanks everyone.
2021-06-30 20:37:11
Try using a different browser on your phone, I use Firefox as well as Chrome. You can download Firefox from Google Play Store. Try setting Firefox as your default browser so that when you try to login to public WiFi you are doing so with Firefox instead of Chrome.
2021-06-30 20:47:12
The UK community has now moved to a new platform. Click Here  If you are in the UK please visit Google Play Store and update the Community app.
To set the default browser go to Settings - Apps - Manage Apps, Then click on the three dots in the top right corner and select default apps. Then click on browser and select which browser you want to set as default.
2021-06-30 20:51:41
The UK community has now moved to a new platform. Click Here  If you are in the UK please visit Google Play Store and update the Community app.

Rookie Bunny

anasxfh Author | from app

#8

South of the Humber
Try using a different browser on your phone, I use Firefox as well as Chrome. Try setting Firefox as your default browser so that when you try to login to public WiFi you are doing so with Firefox instead of Chrome.

will try, many thanks
2021-06-30 20:51:45
please sign in to reply.
Sign In Sign Up

anasxfh

Rookie Bunny

  • Followers

    0

  • Threads

    5

  • Replies

    11

  • Points

    98

Read moreGet new

Xiaomi Comm APP

Stay updated on Mi Products and MIUI

Copyright©2010-2021 Xiaomi.com, All Rights Reserved
Quick Reply To Top Return to the list