that happens to me you should turn on and off flight mode