...Connect via 5g router and try again if available at home...cellular data are slower...i always disable letting phone deplete my quota limited cellular data