In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Mi 8/SE/EE/Lite/Pro

[Discussion] LTE Antenna position - 4G registered - no internet

2020-08-25 06:16:34
291 1
I have replaced the screen and frame for 2 Mi 8 devices, initially, one device had working 4G LTE, I tried to mix and match components so the other device had working 4G LTE as it had my data on, since trying this neither device works with 4G LTE as it should - I have cleaned all parts with isopropyl alcohol thoroughly.
Both devices are able to detect all 4G/3G/2G antennas in my area and register with them all but only gain internet access when using 3G or 2G!?
I'm presuming this is down to a poor antenna connection? I don't know where the LTE antennas are situated, I have highlighted my best guess in the pictures attached in blue, as well as all the contact surfaces to the frame in red. I'm not sure if the frame is used for the LTE antenna, a PCB or the either motherboard cover?? Any help will be much appreciated!
2020-08-25 06:16:34
Favorites RateRate

Semi Pro Bunny

Reskana Chan | from Redmi Note 8 Pro

#1

Follow white or black cable  on picture. these cables end to board with connector. this connector contacted to the antenna.  see the arrow sign on my picture
2020-08-25 15:11:53
please sign in to reply.
Sign In Sign Up

bakerw71

Rookie Bunny

  • Followers

    0

  • Threads

    1

  • Replies

    0

  • Points

    50

Read moreGet new

Mi Comm APP

Stay updated on Mi Products and MIUI

Copyright©2010-2020 Xiaomi.com, All Rights Reserved
Quick Reply To Top Return to the list