In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Mi A3

[Bugs] Android 10 update broke USB-C fast charging on Mi A3

2020-07-29 10:35:22
1930 28
Hi folks,

Could really use some assistance resolving a bizarre issue I'm having with my A3.

My wife and I both bought identical Mi A3s ('Phone 1' and 'Phone 2') and, to take advantage of the fast-charge capacbilities, identical Cygnett PowerPlus 18W chargers (CY3085POPLU, 'Charger 1' and 'Charger 2'). Everything about this setup has worked perfectly on both devices until now.

Yesterday, I accepted the OTA update to Android 10/June security on my phone ('Phone 1').  Ever since, Phone 1 has been unable to charge - upon plugging in the USB-C cable from either Charger 1 or Charger 2, the charging LED light flicks on, I get a notification ping and vibrate, Android flashes up a 'charging slowly' message, then half a second later the phone seems to 'disconnect' from the charging cable only to 'reconnect' again a half-second later, going through all the above again. This carries on endlessly, with Phone 1 sitting there pinging and buzzing away to itself until I remove the cable, never actually charging.

Attempted troubleshooting findings:

  • Phone 1 does not charge from either Charger 1 or Charger 2;
  • Phone 1 does not charge from either Charger 1 or Charger 2 with a different USB-C cable;
  • Phone 1 charged perfectly from both Charger 1 and Charger 2 until the Android 10 update, including charging from Charger 1 all the way through and during the OTA update to Android 10 (phone was plugged in at the time) - fault only started after reboot to apply update;
  • Phone 2 (still on Android 9) works perfectly on both Charger 1 and Charger 2;
  • Phone 2 (still on Android 9) works perfectly on both Charger 1 and Charger 2 with the same USB-C cable used to test Phone 1 with both Charger 1 and Charger 2;
  • Factory reset of Phone 1 after Android 10 update has not resolved issue - continues to be unable to charge from Charger 1 or Charger 2;
  • Other USB-C devices (old Mi A2, Nintendo Switch, Nintendo Switch Lite) all charge without issue from Charger 1 and Charger 2.


Would appreciate any advice on how to resolve this - as far as I can see, the Android 10 update appears to have completely broken USB-C power delivery negotiation on the Mi A3, and I have no idea where to go from here to fix it. Obviously, my wife is very reluctant to apply any updates until this is resolved, which completely defeats the purpose of buying Android One devices.

Any assistance would be gratefully received.

2020-07-29 10:35:22
Favorites2 RateRate

Master Bunny

Daniel Victor | from MI 9

#1

Try to clean charging port of the phone and use original charger included.
2020-07-29 12:03:28

Rookie Bunny

6345250089 Author |

#2

Daniel Victor replied at 2020-07-29 12:03:28
Try to clean charging port of the phone and use original charger included.

Thanks for the suggestions :)

A swab of the charging port with isoprop alcohol has produced no change, and it does not appear damaged or dirty. Further, even if the port was dirty, it seems unlikely that this would be the cause - as above, Phone 1 (at that time running Android 9) was plugged in and charging successfully while receiving the Android 10 OTA update; the problem only started after the phone - still plugged into the same charger - rebooted to apply the Android 10 update.

Further, switching to the charger shipped with the phone will not resolve the issue - the included charger does not provide fast-charge capability.
2020-07-29 12:49:44

Rookie Bunny

6345250089 Author |

#3

I have borrowed a Belkin 'BOOST↑CHARGE' 18W charger from a friend to test with, with the same result as the original Cygnett fast charger - endless 'connected' and 'disconnected' notifications while never actually charging.

Meanwhile, the USB-A output charger supplied by Xiaomi with the phones is able to charge Phone 1 (although only at 'charging slowly'), and Phone 1 is able to connect to a PC to charge and transfer data via a USB-A - USB-C cable.

Accordingly, it seems that:
  • The USB-C port on Phone 1 is not physically damaged;
  • Phone 1 is able to charge slowly via a USB-A - USB-C cable, both from the USB-A output charger supplied by Xiaomi and other devices with USB-A ports; but
  • Phone 1 is no longer able to successfully fast-charge via USB-C since the Android 10 update.


I have also heard from another Mi A2 user that since their phone received the latest Android 10 updates, they also have been unable to fast-charge, with the same issues as I am experiencing above. The problem therefore does not appear to be limited to Phone 1.



2020-07-30 12:45:13

Semi Pro Bunny

Rodrigo_Al | from Mi A3

#4

SAME PROBLEM HERE FROM THE LATEST UPDATE! Man these devs really suck, they just add bugs to the phone instead of fixing them
2020-07-30 14:17:07

Rookie Bunny

6345250089 Author |

#5

That is most annoying. Comments on Reddit suggest that this may be happening to the Mi A2 after latest update as well - can any other A2 or A3 owners confirm?
2020-07-30 16:31:21

Rookie Bunny

6345250089 Author |

#6

Have just had a quick look at the A2 forums and there's a fairly extensive thread with other A2 owners reporting fast charging is broken since the Android 10 update - https://c.mi.com/thread-2832242-1-1.html - so this seems to be a fairly widespread problem? Can any A2 or A3 owners confirm whether they have USB-C fast charging working post the Android 10 update?

2020-07-30 16:38:32
2x A3, stock Android 10 ROM, usb-c charging, generic 5V/2A charger:
- lock screen showing "charging rapidly" message
- accubattery app showing 1.6-1.9A charging speed

I didn't notice any change of charging speed since upgrade to Android 10, it's always been the same.
Btw. it switches to "slow charging" when the battery's charged close to 100%.
2020-07-30 19:59:12

Rookie Bunny

6345250089 Author |

#8

Interesting - I wonder if this is only an issue with chargers supplying the full 18W the Mi A3 is theoretically capable of (your charger would work out to be a 10W, yes?), or if there is some other hardware difference between our phones.  
2020-07-30 21:48:38
Do you have a Qualcomm Quickcharge charger? I am not really familiar with different fast charging types, so not sure that Mi A3 supports USB-C PD which Belkin mentioned before uses. Officially the phone should support Quickcharge 3.0 - I might have one somewhere at home, if I find it I report back if it makes any difference to the 10W (5V/2A) which I use currently.
2020-07-30 22:06:18

Advanced Bunny

Crisjogos | from Mi A3

#10

Same here...get fast charging after 3 or 4 attempts plugin the cord
2020-07-31 10:12:42
please sign in to reply.
Sign In Sign Up

6345250089

Rookie Bunny

  • Followers

    5

  • Threads

    1

  • Replies

    11

  • Points

    38

Read moreGet new

Mi Comm APP

Stay updated on Mi Products and MIUI

Copyright©2010-2020 Xiaomi.com, All Rights Reserved
Quick Reply To Top Return to the list