In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Xiaomi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Other Devices

[Q&A] Can't root my 6A?

2019-12-20 22:25:13
1139 1
So I had a lot of trouble flashing twrp on my 6A, when trying to boot into it my screen would go crazy with red lines only and no menu at all. After trying 4 ou 5 different images I manage to have some kind of twrp mod working, it was the only one that worked.
After that more problems, guides say I'm supposed to flash "lazy flasher" but I get errors about ramdisk problems that I don't know how to fix, so I cant flash it at all. Ok, I tried to flash magisk without lazy flasher and it flashes suscesfully but when my device restart theres no root at all and nothing changes on my system, so what is wrong?

What does lazyflash actually do? Is this necessary to root the device? What I'm missing? I'm freacking tired of wiping my phone and going through MIUI start presentation a hundred times.. lol  

Any help?
2019-12-20 22:25:13
Favorites RateRate
Also, if it makes any difference, my 6A is running Android 9 Pie in MIUI 10
2019-12-20 22:27:01
please sign in to reply.
Sign In Sign Up

obsessedlady

Semi Pro Bunny

  • Followers

    42

  • Threads

    18

  • Replies

    155

  • Points

    607

3 Days Check-In
7 Days Check-In
MIUI 11
10 years
MFF2020

Read moreGet new

Xiaomi Comm APP

Stay updated on Mi Products and MIUI

Copyright©2010-2021 Xiaomi.com, All Rights Reserved
Quick Reply To Top Return to the list