I'm also using Pocophone.But I'm still stuck at 10.3.8.0