brother tell me did you keep your WiFi settings in automatic mode...?