жаль, что только требования от 8 андроида