In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Mi 8/SE/EE/Lite/Pro

[Q&A] MiFlash not showing phone while fastboot does

2019-06-20 14:03:18
107 1
Hey,

At a loss here..
Some context.  Had a custom rom on my Mi 8 for some time now, but want to go back to the global official rom to get googlepay working again.  Or at least try.

So I have done what I needed to on TWRP, now my phones in fastboot.  Fastbook on my laptop detects the device and shows it under 'fastboot devices'.
However, MiFlash does not.  Clicking refresh changes my phone to tiny text saying 'press any key to reboot'. So i do this and it reboots into fastboot again, but nothing shows on MiFlash.  Fastbook cmd still detects the device.. and Miflash seems to be able to send to it..

Any suggestions or fixes would be greatly appreciated!
Thanks! :)


Log only shows this, even on pressing refresh or even just pressing flash, nothing happoens, phone just says press any key to shutdown and reboots. Log remains as this repeated over;

[19:26:26]:get AllUsbDevices
[19:26:26]:GetScriptDevices


2019-06-20 14:03:18
Favorites RateRate
Same issue with my new laptop have usb 3.1.

When I use "fastboot devices" first time, it work.
But second time, my phone disconnect with laptop and show "press any key to shutdown".

I try my old laptop with usb 3.0 and 2.0.
Suprise, all fastboot command work again.

Also I don't know why, but it worked.
2019-07-11 08:13:03
please sign in to reply.
Sign In Sign Up

obbs

Rookie Bunny

  • Followers

    1

  • Threads

    2

  • Replies

    4

  • Points

    48

Read moreGet new
Copyright©2016-2019 Xiaomi.com, All Rights Reserved
Content Policy
Quick Reply To Top Return to the list