Try turning off the option says 'Save to SD card'