Can receive SMS but cannot send?

go system app, choosemessaing and disable mi messaging? worked for me i think